[CRITICAL] "Critical RCE vulnerabilities in PHP (CVE-2026-109618, CVE-2026-109619)"
criticalDetails
Two critical remote code execution (RCE) vulnerabilities, tracked as PHP2Shell (CVE-2026-109618, CVE-2026-109619), allow an unauthenticated attacker to execute arbitrary code on a target web server. The flaws reside in the core PHP runtime, making servers vulnerable regardless of the specific web application code. Multiple sources report active exploitation attempts are already occurring in the wild, and public exploit code is available.
Affected Systems
PHP versions prior to 8.5.12, 8.4.27, 8.3.36, and 8.2.35. This impacts a wide range of web applications and frameworks including WordPress, Drupal, Magento, and Laravel.
Potential Impact
Complete server compromise, leading to data theft, credential harvesting, website defacement, or use of the server for further attacks. Given that nearly 70% of websites use PHP, the potential for widespread impact is exceptionally high.
Mitigations
Immediately apply the emergency security updates. The fixed versions are PHP 8.5.12, 8.4.27, 8.3.36, and 8.2.35. All PHP users are strongly urged to update immediately.